So-net無料ブログ作成

Foxbeans が NetBeans 6.7 Beta でインストールできない [NetBeans]

Firefox 拡張機能を開発するのに便利な NetBeans アドオン foxbeans の続き。

少し調べて見た。原因は NetBeans Forums - Where is pre61completion module and how to solve dependence problem と同じらしい。依存関係の問題。

http://www.teesoft.info/hg/FoxbeansSuite/ から Mercurial を用いてソースコードを取得し、

  • platform-private.properties に platforms.JDK_1.5.home=E:\\Java\\jdk1.5.0_18 を追加。
  • ant.jar を参照に追加
  • その他の依存関係を削除
  • CompletionQuery.java の COMPLETION_TYPE_VALUE 定数を COMPLETION_TYPE_ELEMENT_VALUE に変更

して、ビルドし MBM を作成。この MBM を NetBeans 6.7 Beta にインストールしてみたところ、例外が発生するが、プラグインは有効になった。しかし、Foxbeans で作成したプロジェクトを開いても、正常に認識できていない。

例外が発生しているので、正常に動作しないのは分かるが、ちょっと時間を使いすぎているので、この辺で止めておく。

http://www.teesoft.info/hg/FoxbeansSuite/rev/c176f73176f6 を読むと NetBeans 6.5 でビルド出来るように修正した形跡があるから動作するかなと思ったが、甘かったようだ。


タグ:NetBeans Foxbeans

この広告は前回の更新から一定期間経過したブログに表示されています。更新すると自動で解除されます。

×

この広告は1年以上新しい記事の更新がないブログに表示されております。