So-net無料ブログ作成

古いバージョンの JDK/JRE を入手するには? [NT]

Java はある程度、上位互換性を保っているので、基本的には最新の JDK/JRE を使用すれば足りる。また、古いバージョンではセキュリティに問題がある場合があり、最新の JDK/JRE では修正されていることも多い。

しかし、それでも JDK (Java Development Kit)、JRE (Java Runtime Environment) の古いバージョン(旧バージョン) を必要とすることがたまにある。

例えば、

  • 企業の社内システムで JRE 1.5 でないと動作しない。または、動作保証してくれない。
  • ダウンロードしたサンプルプログラムが JDK 1.2 ベースだった。
  • オープンソースのソフトウェアで開発が止まっているんだけど、ちょっと動かしてみて、大丈夫そうなら使ってみたいが、JDK 1.4 向けに作成されていた。

などなど。少なくとも、エンドユーザが使うべきではなく、開発者向け。基本的にサポートしてくれない。

そんな、古いバージョンの JDK / JRE は次の場所から入手できる。

先に「Java はある程度、上位互換性を保っている」と述べたが、各バージョンについての互換性については次の場所で述べられている。

その他のバージョンの互換性についても上記ページからリンクを辿って確認できる。
タグ:Java programming

この広告は前回の更新から一定期間経過したブログに表示されています。更新すると自動で解除されます。

×

この広告は1年以上新しい記事の更新がないブログに表示されております。